Accessing MySQL on bigdata-labs to practice sqoop

Accessing MySQL on bigdata-labs to practice sqoop
0.0 0


Hi Team,
Do we have mysql database active and accessible on biodata-labs to practice sqoop? If yes, how can we connect it?


Yes mysql is configured. Please watch this video for more details

Mysql host:
User: retail_dba
Password: itversity

Once validated, please close the topic :slight_smile:


while using sqoop its showing error like accumulo imports will fail.


Could you please upload screenshot? So that we can understand the issue better please?


I think we may have to set the accumulo ( $ACCUMULO_HOME to the root of your Accumulo installation ) to root dir. Since it is not set it is failing i believe.

@itversity Durga sir please look into this. Thanks!


sqoop error


Database name is incorrect in your query. It should be retail_db


however, it is a warning. To make the warnings go away we need to install ACCUMULO.

@itversity : Here is the resolution. Might help. Thank you.


Hi Subhash29,

I have fired the same query …this one …



mohit have u seen the screenshot?


Hi subhash29,

We don’t have to do with Accumulo…

On the basis of your screenshot only, I have modified and fired the query.
Do you want to convey something else. Then let me know !!!


its also showing access denied. I think we should have permissions from root to access mysql through sqoop.


It is trying to connect the DB which doesn’t exists ( retail_bd) . Could you please use the correct DB name ( retail_db ) and try please? I think it should work fine. Please let us know if you still run into any issues.


@subhash29 there is typo in connect string. You had retail_bd instead of retail_db
Not sure why you type bd :wink:


Hi Subhash29,

you don’t require the root user.

see this one …


yeah it went well now
thank you mohit


I don’t think this will be causing any problem for your sqoop execution. So you can ignore it for now.


Since the host name is changed now, I am getting error as below.

raghundp@gw01 ~]$ mysql -u retail_dba -h -p
Enter password:
ERROR 1045 (28000): Access denied for user ‘retail_dba’@‘’ (using password: YES)


Host name is not correct. It is not


Hi All,

What is the password for user =root.

I want to run below quarry

mysql -u root -p #if password enabled, else "mysql -u root"
update mysql.user set file_priv = ‘Y’ where user = ‘retail_dba’;