Apache Flume - Error while using flume-ng

flume

#1

can you please restore the permissions to flume.log file?
Someone change it and i am getting permission errors while running flume-ng command.
i have not changed the user permissions for this file as i am not sure on the user details.
thanks!

[krisjskk@gw02 flume-ng]$ pwd
/var/log/flume-ng
[krisjskk@gw02 flume-ng]$ ls -l
total 4
drwxr-xr-x 2 3111 students 4096 Sep 22 00:00 archive
-rw-r–r-- 1 3111 students 0 Sep 22 00:00 flume1.log
-rw-r–r-- 1 abhirajs25 students 0 Oct 8 02:52 flume.log


#2

@Sunil_Itversity can you please help me on this?
this is my example.conf code:

example.conf: A single-node Flume configuration

Name the components on this agent

a1.sources = r1
a1.sinks = k1
a1.channels = c1

Describe/configure the source

a1.sources.r1.type = netcat
a1.sources.r1.bind = localhost
a1.sources.r1.port = 44444

Describe the sink

a1.sinks.k1.type = logger

Use a channel which buffers events in memory

a1.channels.c1.type = memory
a1.channels.c1.capacity = 1000
a1.channels.c1.transactionCapacity = 100

Bind the source and sink to the channel

a1.sources.r1.channels = c1
a1.sinks.k1.channel = c1


#3

Hi @sowmya_jonnalagadda

We are having some internal issues with log4j2 configuration file in labs. It is unable to fetch the messages using telnet. We will let you know once we resolved the issue appreciate your patience.

Regards,
Sunil


#4

Thanks Sunil! i’ll wait for your reply.


#5

@sowmya_jonnalagadda

Can you check now and let us know


#6

i still get the same error.
i have the config file in
/home/krisjskk/flum_demo/


#7

can you the share the flume agent command you run?


#8

i just ran “flume-ng” on the config folder. ideally it should give me the command usage and list out various options to use.


#9

@Sunil_Itversity can you please let me know what the issue is? i just tried to execute the command and it gave me the same permission denied error.

i tried the below command from the config path as well
flume-ng agent --name a1 --conf-file


#10

@sowmya_jonnalagadda
From the location where the conf file is created, you need to run below command

flume-ng agent -n a1 --conf-file example.conf