Cleared CCA175 on 9th January


#1

Hello,

I passed the CCA175 with 9 out of 9 questions.

I got 2 sqoop questions and 7 spark questions. Questions were simple but lag on server might be a problem.

Thanks to Durga sir’s tutorial which helped greatly during preparation.


Prepare for certifications on our state of the art labs which have Hadoop, Spark, Kafka, Hive and other Big Data technologies

  • Click here for signing up for our state of the art 13 node Hadoop and Spark Cluster


#3

Hello Mediant21!
Congratulations and thanks a lot for sharing your exam experience!

I took the exam yesterday, but unfortunately, I failed. So, I am planning to appear the exam again next month or so.
During the exam, my sqoop import/export was keeping failing. I tried the same commands after the exam in the itversity Lab and them success without any problem.

I find that many candidates complained about this issue and I also find out someone said that we should use -P rather than --password in the exam. Is that right? Also, do we need to specify the --split-by command for the primary key?
Another question is about the --connect jdbc:mysql\gateway\problem1 command. Do we need to add :3306 after the hostname ‘gateway’? In the video of Cloudera, they do not add the port number, but when we use the itversity Lab, we need to write the port number after the hostname.

Best!


#4

Port number is not mandatory if it is 3306. If not, you need to specify it.

-P is alternative for --password. It should not matter whether you pass -P or --password. What is the error you got?

You can raise the issue with Cloudera Support and see what they have to say.


#5

Hello Mr @dgadiraju! Thank you for your response!
Every time I tried to run the sqoop command in the exam, I got one error saying my access is denied and one warning that it is safer using -P.
I have sent an email about this issue to Cloudera support, and I am waiting for their reply right now.
Also, for port number, since they only give us the hostname which is gateway, the password, the name of the database, and the name of the target table, but they do not give us the specific port number. So can I write the connect command like this? --connect jdbc:mysql://gateway/problem1


#6

Hi Lan_Wei,

I used -m 1 and --query with $CONDITIONS so i don’t need to use --split-by command. Also i used --password and got no problems.

Thanks