Conf file flume


#1

does not get connected to port 44444


#2

@hhena7777 Can you paste the conf file.


#3

#Copy and paste in the shell from flume user guide

example.conf: A single-node Flume configuration

Name the components on this agent

~ a1.sources = r1
~ a1.sinks = k1
~ a1.channels = c1

Describe/configure the source

~ a1.sources.r1.type = netcat (web server simulator) as it’s a webservice we can telnet into it
~ a1.sources.r1.bind = localhost
~ a1.sources.r1.port = 44444

Describe the sink

~ a1.sinks.k1.type = logger (logger takes those messages print out webserver

Use a channel which buffers events in memory

~ a1.channels.c1.type = memory
~ a1.channels.c1.capacity = 1000
~ a1.channels.c1.transactionCapacity = 100

Bind the source and sink to the channel

~ a1.sources.r1.channels = c1
~ a1.sinks.k1.channel = c1


#4

example.conf: A single-node Flume configuration

Name the components on this agent

a1.sources = r1
a1.sinks = k1
a1.channels = c1

Describe/configure the source

a1.sources.r1.type = netcat (web server simulator) as it’s a webservice we can telnet into it
a1.sources.r1.bind = localhost
a1.sources.r1.port = 44444

Describe the sink

a1.sinks.k1.type = logger (logger takes those messages print out webserver

Use a channel which buffers events in memory

a1.channels.c1.type = memory
a1.channels.c1.capacity = 1000
a1.channels.c1.transactionCapacity = 100

Bind the source and sink to the channel

a1.sources.r1.channels = c1
a1.sinks.k1.channel = c1


#5

this second one I used


#6

Refer this conf file and try

Naming the components on the current agent

a1.sources = r1
a1.channels = m1
a1.sinks = s1

Describing/Configuring the source

a1.sources.r1.type = netcat
a1.sources.r1.bind = localhost
a1.sources.r1.port = 56565
a1.sources.r1.channels = m1

Describing/Configuring the sink

a1.sinks.s1.type = logger
a1.sinks.s1.channel = m1

Describing/Configuring the channel

a1.channels.m1.type = memory
a1.channels.m1.capacity = 1000
a1.channels.m1.transactionCapacity = 100


#7

Hi Balu,
I Used your file but no connectivity. I left this question on Udemy for brother Raju but no response. Its been 9 days since I purchsed lab access but no progress for me.
How can I get help?


#8

I ran your conf file under your user id and it’s able to telnet the port 44444

PFA for reference.