Error bad option: '--master-yarn'

apache-spark

#1

Hi Team,

I tried to launch spark shell with following command
spark-shell --master yarn \
–conf spark.ui.port=12654 \
–num-executors 1 \
–executor-cores 1 \
–executor-memory 512M

And keep getting the error:
bad option: '–master-yarn’
Could you please help on this? Thanks a lot


#2

Hi @tigerwyue,

I can able to run the command what you provided.
Run as below

spark-shell --master yarn --conf spark.ui.port=12654 --num-executors 1 --executor-cores 1 --executor-memory 512M


#3

Thanks Sravan, I rerun the code, and it works now.


#4