Error: Kafka is running on the old version(0.8)


#1

Hi,

When I try to consume a topic using the Kafka using the following command in itversity labs, its throwing as 'Missing required argument “[zookeeper]”.

Command Used:
/usr/hdp/current/kafka-broker/bin/kafka-console-consumer. sh --bootstrap-server nn01.itversity.com:6667 --topic kafka_topic_test --from- beginning

Documentation: https://kafka.apache.org/0110/documentation.html#quickstart_consume

It seems that kafka is using the old version even though it has latest version as per the below image.

image

How can I make sure that Kafka uses latest version?

Many Thanks,
Rakesh


#2

Use the below command it is working fine. We will the details related to version.

kafka-console-consumer.sh \
  --bootstrap-server nn01.itversity.com:6667,nn02.itversity.com:6667,rm01.itversity.com:6667 \
  --zookeeper nn01.itversity.com:2181,nn02.itversity.com:2181,rm01.itversity.com:2181 \
  --topic kafkadg \
  --from-beginning