Error while sqooping

sqoop

#1

Hi used this command,

sqoop import-all-tables --connect “jdbc:mysql://quickstart.cloudera:3306/retail_db” --username retail_dba --password cloudera --warehouse-dir /user/hive/warehouse/problem6.db --hive-import --hive-database problem6 --create-hive-table --as-textfile;

Repeatedly I am facing this error.The error is categories already exists.I even removed the path and tried once again


#2

Hi @Tarun_Teja Table already exist in problem6 database.

image


#3

This is not lab issue. It is tagged incorrectly. This is sqoop issue in your cloudera quick start VM.


#4

Thank you all for the quick response.

The sqoop command I used is ,

sqoop import-all-tables --connect jdbc:mysql://ms.itversity.com:3306/retail_db --username retail_user --password itversity --warehouse-dir /user/tarunsteja/sqoopImport.db --hive-import --hive-database tarunsteja_db --create-hive-table --as-textfile

where DB is tarunsteja_db and i tried to import all the tables from retail_db.
Error Says: categories already exists but There is no point of already exists as I am giving fresh path.


Secondly, When i checked in mysql there is no retail_db but there is retailDB , with out retail_db
database how come it is sqooping categories table.

image

So , What I am trying to do is to import all tables from retail_db i.e orders,categories,departments,orderitems in to the hdfs path provided.But it is failing after importing only categories table not other tables.

Can i get the --username --password of other databases avaliable inorder to proceed with out delay.

Thank you,
Regards,
Tarun Teja