Failed CCA 175 exam on 21th October

cca-175

#1

Hi all,

I have failed CCA 175 exam today. I have passed only 3 problems out of 9, however, I was confident in 7-8 results.
I have been preparing for the exam for 1 month (I was able to dedicate a lot of time - 6-8 hours per day). I took the Udemy course. Then I practiced a lot on problems from itversity and Arun blog several times. There are reasons why I failed:

  1. I didn’t have time to finish 1 problem at all.
  2. The exam environment is slow and not comfortable to use several tabs. For example, I can finish the same task on my environment during 8-10 min but on exam environment - during 15-18 min.
  3. Some problems didn’t have information about delimiter or structure of the file/table. As result, I have spent additional time to validate and understand the structure of file or table. It wasn’t difficult but time-consuming.
  4. For sqoop import, table didn’t have PK. I chose column with name id to split by. It seems it wasn’t correct.
  5. I didn’t have problems about kafka/flume, avro or fill template. I used only Python and sparkSQL to solve all problems.

Tasks were easy. I knew how to do them but it seems I didn’t consider some duplicate values or some other conditions of data (may be null) because I received “Incorrect number of records” in the final report for many problems.


#2

Sorry to hear your result. All the best for next time.
“For sqoop import, table didn’t have PK. I chose column with name id to split by. It seems it wasn’t correct.”

Did you check the table structure ? I guess unless mentioned explicitly table has PK defined.
Did you run eval command to check the structure and then approached the problem ?


#3

I am sorry to hear about your results. But there’s another perspective to it.

Do we need certifications to certify our knowledge? Or is it good enough if we are able to demonstrate the knowledge by way of PoC’s?

It happened to me. speaking from my experience. I am a java guy for more than a decade with knowledge of the latest buzzwords doing the rounds.

In early 2008, i was crazy about certification. That’s when i did Java certification. There’s this another guy called Pai from Pune who said come what may, i despise certification. They don’t hold value to me. I am passionate about Java. and that’s all that matters. subsequently i completed java and also another certification called JPA. and Pai was still not certified.
and Then i thought i should add another feather to my collection EJB Java Business component developer. I went and bought O’Reilly’s book. and guess who was the co-author or proof reader of the book. You guessed it right the same Pai who didn’t give a damn about certification but just followed his passion.

Do certification really matter? It’s all because we attach importance to it and companies do not give a damn either. they just want to get the work done and get their billings! They are like
‘Do we look like we give a damn?’ Well they may if they find their business provider isn’t happy with existing lot and they need to prove their worthiness to their masters!

Let’s give it a thought.

As for you Tanya, good that you tried. You should feel proud about it and get on with it.

Regards
VB


#5

I connected to MySQL instance (all information about the connection to db was provided in the task) and run the command “describe table_name”. It didn’t have PK but had a column with name id and type varchar. Technically it is possible for MySql DB. I don’t know what exam creators wanted to achieve in this task.


#4

Do the next attempt at certification if your company is willing to sponsor you for it! Skip otherwise…


#6

Hi Vinay,

I agree with you that the most important is what value will you bring to a company with or without certification.
However, if you don’t have work experience in some technology and don’t receive calls from recruiters then you can receive a certificate or do some project.

I am happy that I tried to pass the certificate. I realized that I have the necessary knowledge and I can solve these problems and that the only problem is that I did not understand some cunning plans of the examiners, which in real work is not particularly necessary.