Failed the exam - this is why - please read for your benefit


#1

To avoid these kind of issues, at ITVersity we are coming up with Certification simulator. For now send email to training@itversity.com. It costs $14.45 per week


Adding this note on May 25 2018
I passed this exam today on my second attempt

Give it a shot !.. see if you are ready for the exam. Good Luck!

Below posting was done in April when during my first attempt


not really a success story :frowning: - failed the exam today

For some reason the mysql command did not connect to the cloudera mysql.
I could not answer 2 out of 9 questions involving mysql.
and I made mistake on another question . so I failed

I tried labs type of mysql connectivity to check table/column. but could not connect
mysql -u username -h hostname
i got access denied error repeatedly.
Even through sqoop command same error.
I tried opening fresh terminal etc. still same error.
No idea what I did wrong.

If any of you had similar hiccups and managed to make it work please let me know. Thanks a ton!

I lost 25 minutes due to this mysql drama

The reason third question was incorrect because I by mistake deleted the input hdfs directory for that question
using hadoop fs -rm xxxx
(while deleting another junk output… i deleted the input data directory for one of the problems . once you lose source hdfs data dir… you cant do anything. be careful. It sucks that they made the source data RWX… it should be just read permission )

I am still wondering what went wrong with mysql connection. environment issue or my own ignoring. not sure.

But exam will be very easy . no complications. if you practice durga/arun exercises… you will be very comfortable. Unfortunately i goofed up.

practice various input/output formats along with compression.

make sure you open fresh spark shell if one question involved compression and another one uncompressed for same output format. if you use same shell and if you forget not to reset compression output will be wrong
setContext.setconf(“spark.sql.avro.compression.codec”,“uncompressed”) --> use this to reset the compression for same spark shell. or exit and launch new spark shell


Based on my experience this is what you need to pass

#Once you are done with udemy sessions of reading/review/memorizing commands
#Practice Arun’s blog and the problem scenarios listed there
(Especially on various input output formats and compression techniques)
#Learn Avro package import and passing through spark shell launch
#Learn handling sequence file of K,V for both writing and reading and processing V … and write values into new format
#Learn technique of one key ascending, another key descending using (K1,-K2)
#Practice Durga exercises

Memorize package names etc. saves time (avro pkg , compression pkg. databricks pkg for avro etc)
also memorize all sqoop commands, not that hard to memorize

#sqoop - master this and nail the questions you may receive in exam
#HDFS read / RDD . transformation , action , simple join . saving in text or some other output with or without compression
#Hive DB read through HiveContext

#Don’t break your head with complicated flume/kafka. simple flume/exec command good enough … just in case if you are asked in exam

Thank you very much for Durga and his Team for (udemy and awesome labs setup)


Here are the coupons for CCA exams which cover all important aspects of the examination.

  • Click here for $35 coupon for CCA 175 Spark and Hadoop Developer using Python.
  • Click here for $35 coupon for CCA 175 Spark and Hadoop Developer using Scala.
  • Click here for signing up for our state of the art labs for hands on practice

Thank you very much for Arun’s blog . Problem scenarios are very good


Prepare for certifications on our state of the art labs which have Hadoop, Spark, Kafka, Hive and other Big Data technologies

  • Click here for signing up for our state of the art 13 node Hadoop and Spark Cluster


#15

hi,are they asking to solve a problem specifically using RDD, or Spark sql anything like that?? because i am more comfortable using spark sql


#2

As most of the others are able to clear the exam, most probably you might be doing something wrong.

Let us discuss further over phone.


#17

they just give input and define the expected output. Up to you to write your code/logic
My approach is… if one or two tables with simple join and getting data without any complex aggregation I would go with RDD.
If more than 2 tables involved or fancy analytic logic involved then I would go with registerTempTable(“xyz”) and use the temp table for writing myDF=sqlContext.sql(“xxxxxx from xyz xxxxxxx”)


#3

I had a similar issue, but it was a minute one as I was used to CTRL+C and CTRL+V and not CTRL+ SHIFT+V and since password it hidden, I was not sure if the password was pasted.


#4

Just wondering what was wrong with the MySQL DB connection, has anyone faced similar issue ? the user said the error was access denied so any reason why the user got this error ?


#5

I saw 2 other ppl having same connection issues with MYSQL and not able to clear their tests.


#6

And in this situation, what happen, do they give you another free attempt or you get reimbursed ?


#7

They typically give free retake if there is issue on their side.


#16

just wanted to close this topic with final update.
I was told by cloudera that “mysql -u username -h hostname” is not expected to work in cloudera env. (even though in itversity labs it works)
For me sqoop command did not work either until last minute … last minute i tried something and i got different error (other than access denied) . Probably something got rectified in mysql access permission and it started working (but time froze and I could not do anything) or i must have done some syntax mistake . unclear at this point. Nevertheless … the fault is on my side somehow.

As Durga advised… use sqoop eval to try your mysql SQL or any sql to get schema info of mysql table instead of using mysql command. sqoop eval is the way to go to probe mysql tables and your queries. which I did not attempt in my exam. If you face any error move on to other questions and come back to mysql/sqoop by attempting in a freshly opened terminal.

Also dont delete the HDFS source data directory by mistake. Be very careful while issuing any rm command for deleting temp/junk output.

Probably I will retake the exam after a month or so.

Good Luck to all of you!


#21

I passed this exam today on my second attempt. My feedback here


#8

@dgadiraju sir, Did you found root cause for jayshawusa facing this access issue? If yes, Please share here. So that, we will not make the same mistake. Thanks!


#9

Thanks for the reply, I would also be keen as @harinatha said, if there’s a solution for this issue.


#10

As of now no. Cloudera folks seem to came back saying that every thing is fine from their end. As hundreds of people have taken the certification in last 1 year, the probability is high that there might be some minor issue in the approach of @jayshawusa


#11

Hi @jayshawusa

Where i can find the “Durga exercise” you are referring to?
Could you post the link?

Thank you


#12

Here are some of the exercises:

http://discuss.itversity.com/c/certifications/spark-exercises
http://discuss.itversity.com/c/big-data/workshop-exercises

Exercises that are referred by Jay are part of our Udemy courses. They are similar to what I have referred above.


#13

Ok, thank you .
I’m a member of Udemy, where i can find the exercises?


#14

Towards the end of the course. Python one is yet to be updated with the solutions.

These are the questions for which I have provided solutions using Scala. I will provide solutions using Python as well soon.

http://discuss.itversity.com/c/certifications/spark-exercises


#18

@jayshawusa, @dgadiraju

Hello,

Could you please share the mysql login format that will work in Cloudera exam environment.

Thanks & Regards


#19

You should not run mysql command at all. That’s the whole point of this discussion. Use
sqoop eval
–connect
–username \
–password
–table
–columns \

or
–query

to access the database and see the structure