Flume is not working


#1

Hi, I’m getting the below error when I start flume using the command:
flume-ng agent -n whk -f /home/prady3041/wslogs/wslogs.conf

ve org.apache.flume.node.Application -n wh -f /home/prady3041/wslogs/wslogs.conf
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/usr/hdp/2.6.5.0-292/flume/lib/log4j-slf4j-impl-2.10.0.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/hdp/2.6.5.0-292/flume/lib/slf4j-log4j12-1.7.10.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console. Set system property ‘log4j2.debug’ to show Log4j2 internal initialization logging.

The configuration file i’m using is below:

whk.sources = ws
whk.sinks = k1
whk.channels = mem

Describe configure the source

whk.sources.ws.type = exec
whk.sources.ws.command = tail -F /opt/gen_logs/logs/access.log

Describe the sink

whk.sinks.k1.type = logger

Use a channel which buffers events in memory

whk.channels.mem.type = memory
whk.channels.mem.capacity = 1000
whk.channels.mem.transactionCapacity = 100

Bind the source and sink to the channel

whk.sources.ws.channels = mem
whk.sinks.k1.channel = mem


#2

@Pradeep_Kannadiga refer to the link Flume ERROR StatusLogger No log4j2 configuration file found


#3

Hi,

It is still not working. May be it is problem with my classpath??? Please use the below command and check if you are also getting the same issue.

I have tried the below commands:
flume-ng agent --name a1 --conf-file test1.conf --conf /home/prady3041/flume_conf

flume-ng agent --name a1 --conf-file /home/prady3041/flume_conf/test1.conf --conf /home/prady3041/flume_conf

Both the options did not work. Please help. I’m struck with this issue.


#4

@Pradeep_Kannadiga You have to run the command like below, Please refer above link.

flume-ng agent -n whk -f /home/prady3041/wslogs/wslogs.conf --conf /etc/flume/conf