Flume: Not able to ping Localhost


#1

Hi Team,

I am not able to ping localhost. Is there something that I am going wrong:

[shubhaprasadsamal@gw01 ~]$ telnet localhost
Trying 127.0.0.1…
telnet: connect to address 127.0.0.1: Connection refused
[shubhaprasadsamal@gw01 ~]$ ping localhost
ping: icmp open socket: Operation not permitted
[shubhaprasadsamal@gw01 ~]$ hostname -f
gw01.itversity.com
[shubhaprasadsamal@gw01 ~]$ ping gw01.itversity.com
ping: icmp open socket: Operation not permitted
[shubhaprasadsamal@gw01 ~]$ ifconfif -a
bash: ifconfif: command not found…
[shubhaprasadsamal@gw01 ~]$ ifconfig -a
bond0: flags=5122<BROADCAST,MASTER,MULTICAST> mtu 1500
ether 36:91:a1:ca:ea:cb txqueuelen 0 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Please suggest. Thanks, Shitansu


#2

Same issue i’m also not able to ping to localhost (or) telnet localhost …
Any help from anyone ?

[babuganesh2k@gw01 ~]$ ping localhost
ping: icmp open socket: Operation not permitted

[babuganesh2k@gw01 ~]$ telnet localhost 40404
Trying 127.0.0.1…
telnet: connect to address 127.0.0.1: Connection refused
[babuganesh2k@gw01 ~]$ telnet localhost 44444
Trying 127.0.0.1…
telnet: connect to address 127.0.0.1: Connection refused
[babuganesh2k@gw01 ~]$ telnet localhost 55555
Trying 127.0.0.1…
telnet: connect to address 127.0.0.1: Connection refused
[babuganesh2k@gw01 ~]$ pwd
/home/babuganesh2k


#3

I am not able to ping flume with below commands now also:

[shubhaprasadsamal@gw03 ~]$ telnet gw01.itversity.com 44444
Trying 172.16.1.100…
telnet: connect to address 172.16.1.100: Connection refused
[shubhaprasadsamal@gw03 ~]$ telnet nn01.itversity.com 44444
Trying 172.16.1.101…
telnet: connect to address 172.16.1.101: Connection refused
[shubhaprasadsamal@gw03 ~]$ telnet nn01.itversity.com 12345
Trying 172.16.1.101…
telnet: connect to address 172.16.1.101: Connection refused
[shubhaprasadsamal@gw03 ~]$ telnet (nc) nn01.itversity.com 12345
-bash: syntax error near unexpected token nc' [shubhaprasadsamal@gw03 ~]$ telnet (or nc) nn01.itversity.com 12345 -bash: syntax error near unexpected tokenor’
[shubhaprasadsamal@gw03 ~]$ nc nn01.itversity.com 44444
Ncat: Connection refused.
[shubhaprasadsamal@gw03 ~]$ nc nn01.itversity.com:44444
Ncat: Could not resolve hostname “nn01.itversity.com:44444”: Name or service not known. QUITTING.
[shubhaprasadsamal@gw03 ~]$

Is this issue is not fixed or am I doing something wrong.

Also, below is my flume agent:

[shubhaprasadsamal@gw03 ~]$ cd /home/shubhaprasadsamal/flume
[shubhaprasadsamal@gw03 flume]$ ls
derby.log problem7_1
[shubhaprasadsamal@gw03 flume]$ vi example.conf
[shubhaprasadsamal@gw03 flume]$ ls
derby.log example.conf problem7_1
[shubhaprasadsamal@gw03 flume]$ cat example.conf
a1.sources = r1
a1.sinks = k1
a1.channels = c1

a1.sources.r1.type = netcat
a1.sources.r1.bind = gw01.itversity.com
a1.sources.r1.port = 44444

a1.sinks.k1.type = logger

a1.channels.c1.type = memory
a1.channels.c1.capacity = 1000
a1.channels.c1.transactionCapacity = 100

a1.sources.r1.channels = c1
a1.sinks.k1.channel = c1

[shubhaprasadsamal@gw03 flume]$ flume-ng agent -n a1 --conf /home/shubhaprasadsamal/flume/ --conf-file example.conf

Facing below ERROR:

18/04/25 14:44:59 INFO node.Application: Starting Channel c1
18/04/25 14:45:00 INFO instrumentation.MonitoredCounterGroup: Monitored counter group for type: CHANNEL, name: c1: Successfully registered new MBean.
18/04/25 14:45:00 INFO instrumentation.MonitoredCounterGroup: Component type: CHANNEL, name: c1 started
18/04/25 14:45:00 INFO node.Application: Starting Sink k1
18/04/25 14:45:00 INFO node.Application: Starting Source r1
18/04/25 14:45:00 INFO source.NetcatSource: Source starting
18/04/25 14:45:00 ERROR source.NetcatSource: Unable to bind to socket. Exception follows.
java.net.BindException: Cannot assign requested address
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:67)
at org.apache.flume.source.NetcatSource.start(NetcatSource.java:162)
at org.apache.flume.source.EventDrivenSourceRunner.start(EventDrivenSourceRunner.java:44)
at org.apache.flume.lifecycle.LifecycleSupervisor$MonitorRunnable.run(LifecycleSupervisor.java:251)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
18/04/25 14:45:00 ERROR lifecycle.LifecycleSupervisor: Unable to start EventDrivenSourceRunner: { source:org.apache.flume.source.NetcatSource{name:r1,state:IDLE} } - Exception follows.
org.apache.flume.FlumeException: java.net.BindException: Cannot assign requested address
at org.apache.flume.source.NetcatSource.start(NetcatSource.java:168)
at org.apache.flume.source.EventDrivenSourceRunner.start(EventDrivenSourceRunner.java:44)
at org.apache.flume.lifecycle.LifecycleSupervisor$MonitorRunnable.run(LifecycleSupervisor.java:251)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.BindException: Cannot assign requested address
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)

Can you help me?

Thanks