HDPCA - Wierd Error while installing ambari-metrics - related to kerbores library

Video No 19 from the list: Amazon Webservices -Virtual Machine -Setup Ambari Agents

I have followed all the videos including this one for all the required set up
I have 6 Ec2-Instances (3 Masters / 3 Slaves). 1 has Public IP (My Main Server) and 5 have EIP.

I executed the command from the error , on my main EC2 instance , Master01

[ec2-user@ip-172-31-7-74 ~]$ sudo yum -d 0 -e 0 -y install ambari-metrics-monitor
ERROR with rpm_check_debug vs depsolve:
libkadm5clnt_mit.so.8()(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5srv_mit.so.8()(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2017-03-25-07-01vjZxht.yumtx

I could not really find anything specific on net:
https://www.rpmfind.net/linux/rpm2html/search.php?query=libkadm5clnt_mit.so.8()(64bit)
https://rhn.redhat.com/errata/RHBA-2017-0643.html

Would be helpfull, if anybody can shed some insights !

  • Either i start over again and do as the video , potentially could end up with same issue.
    -Start over and use hortonworks links to download repos on all servers rather than pushing repo fro master server to all

Errors:
--------------------------------------------------------------------
/var/lib/ambari-agent/data/errors-107.txt
--------------------------------------------------------------------
Repository Updates-ambari-2.1.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository HDP-2.3.0.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository Updates-ambari-2.1.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository HDP-2.3.0.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository Updates-ambari-2.1.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository HDP-2.3.0.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository Updates-ambari-2.1.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Repository HDP-2.3.0.0 is listed more than once in the configuration
Repository HDP-UTILS-1.1.0.20 is listed more than once in the configuration
Traceback (most recent call last):
File “/var/lib/ambari-agent/cache/common-services/AMBARI_METRICS/0.1.0/package/scripts/metrics_monitor.py”, line 58, in
AmsMonitor().execute()
File “/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py”, line 218, in execute
method(env)
File “/var/lib/ambari-agent/cache/common-services/AMBARI_METRICS/0.1.0/package/scripts/metrics_monitor.py”, line 28, in install
self.install_packages(env, exclude_packages = [‘ambari-metrics-collector’])
File “/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py”, line 376, in install_packages
Package(name)
File “/usr/lib/python2.6/site-packages/resource_management/core/base.py”, line 157, in init
self.env.run()
File “/usr/lib/python2.6/site-packages/resource_management/core/environment.py”, line 152, in run
self.run_action(resource, action)
File “/usr/lib/python2.6/site-packages/resource_management/core/environment.py”, line 118, in run_action
provider_action()
File “/usr/lib/python2.6/site-packages/resource_management/core/providers/package/init.py”, line 45, in action_install
self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
File “/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py”, line 49, in install_package
shell.checked_call(cmd, sudo=True, logoutput=self.get_logoutput())
File “/usr/lib/python2.6/site-packages/resource_management/core/shell.py”, line 70, in inner
result = function(command, **kwargs)
File “/usr/lib/python2.6/site-packages/resource_management/core/shell.py”, line 92, in checked_call
tries=tries, try_sleep=try_sleep)
File “/usr/lib/python2.6/site-packages/resource_management/core/shell.py”, line 140, in _call_wrapper
result = _call(command, **kwargs_copy)
File “/usr/lib/python2.6/site-packages/resource_management/core/shell.py”, line 291, in _call
raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install ambari-metrics-monitor’ returned 1. ERROR with rpm_check_debug vs depsolve:
libkadm5clnt_mit.so.8()(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5srv_mit.so.8()(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit) is needed by krb5-workstation-1.10.3-65.el6.x86_64
You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2017-03-25-06-305zHb5j.yumtx

--------------------------------------------------------------------
/var/lib/ambari-agent/data/output-107.txt
--------------------------------------------------------------------

2017-03-25 06:30:20,223 - Directory[’/var/lib/ambari-agent/data/tmp/AMBARI-artifacts/’] {‘recursive’: True}
2017-03-25 06:30:20,225 - File[’/var/lib/ambari-agent/data/tmp/AMBARI-artifacts//jce_policy-8.zip’] {‘content’: DownloadSource(‘http://ip-172-31-7-74.ap-southeast-2.compute.internal:8080/resources//jce_policy-8.zip’)}
2017-03-25 06:30:20,225 - Not downloading the file from http://ip-172-31-7-74.ap-southeast-2.compute.internal:8080/resources//jce_policy-8.zip, because /var/lib/ambari-agent/data/tmp/jce_policy-8.zip already exists
2017-03-25 06:30:20,226 - Group[‘hadoop’] {‘ignore_failures’: False}
2017-03-25 06:30:20,226 - User[‘zookeeper’] {‘gid’: ‘hadoop’, ‘ignore_failures’: False, ‘groups’: [‘hadoop’]}
2017-03-25 06:30:20,227 - User[‘ams’] {‘gid’: ‘hadoop’, ‘ignore_failures’: False, ‘groups’: [‘hadoop’]}
2017-03-25 06:30:20,228 - User[‘ambari-qa’] {‘gid’: ‘hadoop’, ‘ignore_failures’: False, ‘groups’: [‘users’]}
2017-03-25 06:30:20,228 - File[’/var/lib/ambari-agent/data/tmp/changeUid.sh’] {‘content’: StaticFile(‘changeToSecureUid.sh’), ‘mode’: 0555}
2017-03-25 06:30:20,229 - Execute[’/var/lib/ambari-agent/data/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa’] {‘not_if’: ‘(test $(id -u ambari-qa) -gt 1000) || (false)’}
2017-03-25 06:30:20,240 - Skipping Execute[’/var/lib/ambari-agent/data/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa’] due to not_if
2017-03-25 06:30:20,256 - Repository[‘HDP-2.3’] {‘base_url’: ‘http://ec2-52-62-208-166.ap-southeast-2.compute.amazonaws.com/yum/HDP/centos6/2.x/updates/2.3.0.0’, ‘action’: [‘create’], ‘components’: [‘HDP’, ‘main’], ‘repo_template’: ‘[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0’, ‘repo_file_name’: ‘HDP’, ‘mirror_list’: None}
2017-03-25 06:30:20,265 - File[’/etc/yum.repos.d/HDP.repo’] {‘content’: InlineTemplate(…)}
2017-03-25 06:30:20,266 - Writing File[’/etc/yum.repos.d/HDP.repo’] because it doesn’t exist
2017-03-25 06:30:20,266 - Repository[‘HDP-UTILS-1.1.0.20’] {‘base_url’: ‘http://ec2-52-62-208-166.ap-southeast-2.compute.amazonaws.com/yum/HDP-UTILS-1.1.0.20/repos/centos6’, ‘action’: [‘create’], ‘components’: [‘HDP-UTILS’, ‘main’], ‘repo_template’: ‘[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0’, ‘repo_file_name’: ‘HDP-UTILS’, ‘mirror_list’: None}
2017-03-25 06:30:20,269 - File[’/etc/yum.repos.d/HDP-UTILS.repo’] {‘content’: InlineTemplate(…)}
2017-03-25 06:30:20,269 - Package[‘unzip’] {}
2017-03-25 06:30:20,365 - Skipping installation of existing package unzip
2017-03-25 06:30:20,366 - Package[‘curl’] {}
2017-03-25 06:30:20,408 - Skipping installation of existing package curl
2017-03-25 06:30:20,408 - Package[‘hdp-select’] {}
2017-03-25 06:30:20,450 - Installing package hdp-select (’/usr/bin/yum -d 0 -e 0 -y install hdp-select’)
2017-03-25 06:30:22,167 - Directory[’/var/lib/ambari-agent/data/tmp/AMBARI-artifacts/’] {‘recursive’: True}
2017-03-25 06:30:22,168 - File[’/var/lib/ambari-agent/data/tmp/jdk-8u40-linux-x64.tar.gz’] {‘content’: DownloadSource(‘http://ip-172-31-7-74.ap-southeast-2.compute.internal:8080/resources//jdk-8u40-linux-x64.tar.gz’), ‘not_if’: ‘test -f /var/lib/ambari-agent/data/tmp/jdk-8u40-linux-x64.tar.gz’}
2017-03-25 06:30:22,178 - Skipping File[’/var/lib/ambari-agent/data/tmp/jdk-8u40-linux-x64.tar.gz’] due to not_if
2017-03-25 06:30:22,179 - Directory[’/usr/jdk64’] {}
2017-03-25 06:30:22,180 - Execute[’(‘chmod’, ‘a+x’, ‘/usr/jdk64’)’] {‘not_if’: ‘test -e /usr/jdk64/jdk1.8.0_40/bin/java’, ‘sudo’: True}
2017-03-25 06:30:22,189 - Skipping Execute[’(‘chmod’, ‘a+x’, ‘/usr/jdk64’)’] due to not_if
2017-03-25 06:30:22,190 - Execute[‘mkdir -p /var/lib/ambari-agent/data/tmp/jdk && cd /var/lib/ambari-agent/data/tmp/jdk && tar -xf /var/lib/ambari-agent/data/tmp/jdk-8u40-linux-x64.tar.gz && ambari-sudo.sh cp -rp /var/lib/ambari-agent/data/tmp/jdk/* /usr/jdk64’] {‘not_if’: ‘test -e /usr/jdk64/jdk1.8.0_40/bin/java’}
2017-03-25 06:30:22,199 - Skipping Execute[‘mkdir -p /var/lib/ambari-agent/data/tmp/jdk && cd /var/lib/ambari-agent/data/tmp/jdk && tar -xf /var/lib/ambari-agent/data/tmp/jdk-8u40-linux-x64.tar.gz && ambari-sudo.sh cp -rp /var/lib/ambari-agent/data/tmp/jdk/* /usr/jdk64’] due to not_if
2017-03-25 06:30:22,199 - File[’/usr/jdk64/jdk1.8.0_40/bin/java’] {‘mode’: 0755, ‘cd_access’: ‘a’}
2017-03-25 06:30:22,201 - Execute[’(‘chgrp’, ‘-R’, ‘hadoop’, ‘/usr/jdk64/jdk1.8.0_40’)’] {‘sudo’: True}
2017-03-25 06:30:22,231 - Execute[’(‘chown’, ‘-R’, ‘root’, ‘/usr/jdk64/jdk1.8.0_40’)’] {‘sudo’: True}
2017-03-25 06:30:22,441 - Package[‘ambari-metrics-monitor’] {}
2017-03-25 06:30:22,539 - Installing package ambari-metrics-monitor (’/usr/bin/yum -d 0 -e 0 -y install ambari-metrics-monitor’)

After some googling I did the following on all hosts and then i tried the CLUSTER INSTALL WIZARD from AMBARI again for Metrics Collector and Zookeeper installation on all EC2 nodes.

It worked !! :slight_smile:

[ec2-user@ip-172-31-5-78 ~]$ yum install libkadm5

NOTE: This potentially can happen on AWS RHEL AMIs , hence the above patch could handy as a preventative measure.

2 Likes

Thank you @kfactor21 , this helped me

Thanks @kfactor21 ! You saved the day ! :slight_smile: