HDPCD Task 01 Certification


#1

Hi,
I am currently working on the Hortonworks practice exam and I am getting errors I have not been able to troubleshoot.
During the first step the prompt asks Put the three files from the home/horton/datasets/flightdelays directory on the local machine into the user/horton/flight_delays directory in hdfs permission denied error. HDPCDWhen on the node that hdfs is installed on (root@namenode). I run the simple command:
hadoop fs -copyFromLocal /home/horton/datasets/flightdelays/flight_delays1.csv /user/horton/flightdelays
This returns the error /home/horton/datasets/flightdelays/flight_delays1.csv no such file or directory
When I run the same exact command above from the command line on the local machine instead of running it after being ssh’d onto the namenode (horton@some-ip) I get a permission denied error:
permission denied user=horton access=WRITE inode=’/user/horton/flightdelays":hdfs:hdfs:drwxr-xr-x
can you please help me?


#2

Does the folder flightdelays exist in your hdfs? thanks


#3

@RanjeetHDP:

You need to have files (flight_delays1. * ) in directory /home/horton/datasets/flightdelays in Local FS (on gateway node) before you move from there.

After this, if you still face permissions error, try to give read permissions to your file using:
$ chmod 400 <FILE_NAME>

Hope this helps.
Thanks
Venkat


#4

Yes, it does. I can see flightdelays folder