"import all tables " failed


#1

Hi I was trying to use the “import all tables”. I see these errors

[katukurivamshikrishna@gw02 ~]$ sqoop import-all-tables -m 12 --connect jdbc:mysql://ms.itversity.com:3306/retail_db --username retail_user --password itversity --as-textfile --warehouse-dir = /user/hive/warehouse/testdb.db
Warning: /usr/hdp/2.5.0.0-1245/accumulo does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
18/06/28 14:00:36 INFO sqoop.Sqoop: Running Sqoop version: 1.4.6.2.5.0.0-1245
18/06/28 14:00:36 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.
18/06/28 14:00:36 ERROR tool.BaseSqoopTool: Error parsing arguments for import-all-tables:
18/06/28 14:00:36 ERROR tool.BaseSqoopTool: Unrecognized argument: /user/hive/warehouse/testdb.db


#2

Hi ,

Plz try this one.

sqoop import-all-tables -m 12 --connect jdbc:mysql://ms.itversity.com:3306/retail_db --username retail_user --password itversity --as-textfile --warehouse-dir /user/hive/warehouse/testdb.db


#3

It worked, thanks!, I think in Durga’s notes on github, all inputs like password, username and path all are with “=” and that made me confused. I dunno if that’s how it is used on Cloudera VM.