Issue with Sqoop excution Time


#1

Hi,

I have executed below sqoop commands and it took long time to finish the sqoop job. Is this issue with environment or any issue with my sqoop command.

sqoop import --connect jdbc:mysql://nn01.itversity.com/retail_db \

–username retail_dba
–password itversity
–table order_items
–where ‘order_item_order_id <10’
–as-avrodatafile
–target-dir ‘/user/satishp38/sqoop201806/orderitems_import_using_asavrofile’
Warning: /usr/hdp/2.5.0.0-1245/accumulo does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
18/06/09 16:35:57 INFO sqoop.Sqoop: Running Sqoop version: 1.4.6.2.5.0.0-1245
18/06/09 16:35:57 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.

18/06/09 17:35:20 INFO mapreduce.ImportJobBase: Transferred 3.8447 KB in 3,558.452 seconds (1.1064 bytes/sec)

sqoop import --connect jdbc:mysql://nn01.itversity.com/retail_db \

–username retail_dba
–password itversity
–table orders
–as-textfile
–target-dir ‘/user/satishp38/sqoop201806/order_import_using_astextfile’
Warning: /usr/hdp/2.5.0.0-1245/accumulo does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
18/06/09 16:16:21 INFO sqoop.Sqoop: Running Sqoop version: 1.4.6.2.5.0.0-1245

18/06/09 17:35:03 INFO mapreduce.ImportJobBase: Transferred 2.861 MB in 4,718.8152 seconds (635.7409 bytes/sec)
18/06/09 17:35:03 INFO mapreduce.ImportJobBase: Retrieved 68883 records.