Issues with Sqoop in CCA175


#1

Hi guys,
I gave certification yesterday night.I couldn’t clear the certification.The certification is in old format only
Things to be noted:-
1.The cluster is very damn slow. The text is getting displayed in VM after 10 seconds after you typed here.
2.Time management is the key. I failed because I’m unable to manage time accordingly.Wasted 30 mins on sqoop questions.
3. Don’t try to touch all the questions. Make sure first atleast 7 questions are answered. Target for 7 answers to be correct.

They have a 25 million records in table. I wrote the command accordingly
sqoop import --connect “connection string” --username cloudera --password cloudera --table table-name --target-dir “/x/y/z” --as-texfile
When i connected to db using sqoop and ran eval queries it worked fine. But when i ran the import jobs it failed because of connection error. Im unable to answer import and export questions because of this .Not sure what exactly went wrong :frowning:
I’m unable to figure out what exactly went wrong in above command.


#2

Dont worry mate … It happens… Just take it in your stride and move forward…
Hope you will clear this certification with flying colors… :v: :slight_smile:


#3

How did you get to know the connection string in the exam ? like i need to know the hostname of the name node , not the gateway node.

    [rajeshs@gw02 ~]$ hostname -f;
gw02.itversity.com

this one is hostname but when we want to connect to DB we need to have connection string like
--connect jdbc:mysql://nn01.itversity.com:3306/retail_db \
right ?

Can you please help me clearing this doubt ?