Kafka starting issue


#1

Dear Itversity-Team,

I’m using the labs and unfortunately can’t start kafka. I configured the file vi ~/.bash_profile
as follows:
PATH=$PATH:$HOME/.local/bin:$HOME/bin

export KAFKA_HOME=/usr/hdp/2.5.0.0-1245/kafka
PATH=$PATH:$KAFKA_HOME/bin

export PATH
export CQLSH_HOST=csql.itversity.com

When I run kafka, I get: /bin/kafka {start|stop|status|clean}
When i run kafka status: Kafka Can’t find pid dir.

Please, let me know what I should do. Thanks for you help.


#2

Please paste the kafka command that you are using.


#3

[alexandergsv@gw03 ~]$ kafka
Usage: /bin/kafka {start|stop|status|clean}
[alexandergsv@gw03 ~]$ kafka status
Kafka Can’t find pid dir.
[alexandergsv@gw03 ~]$ kafka start
Can’t find pid dir.
[alexandergsv@gw03 ~]$


#4

Kafka already running on the labs. You can use the below link to get start with Kafka on Labs.


#5

Hi,
I know that kafka is running on the labs but i still have the same problem and it’s not clear to me what is wrong and how to fix. I get the answer command not found.

  1. I run these commands
    export KAFKA_HOME=/usr/hdp/2.5.0.0-1245/kafka
    export PATH=$PATH:$KAFKA_HOME/bin

  2. Then, run:
    [alexandergsv@gw03 ~]$ kafka-topics.sh --list --zookeeper nn01.itversity.com:2181,nn02.itversity.com:2181,rm01.itversity.com:2181
    bash: kafka-topics.sh: command not found…


#6

@Alexander Please refer the link and use the updated paths