Pig - Getting Error when use org.apache.pig.piggybank.evaluation.string.UPPER


#1

grunt> departments_upper = FOREACH departmentsjar GENERATE department_id,org.apache.pig.piggybank.evaluation.string.UPPER(department_name) AS department_name;
2018-01-13 07:42:16,572 [main] INFO org.apache.hadoop.conf.Configuration.deprecation - fs.default.name is deprecated. Instead, use fs.defaultFS
2018-01-13 07:42:16,618 [main] INFO hive.metastore - Closed a connection to metastore, current connections: 0
2018-01-13 07:42:16,619 [main] INFO hive.metastore - Trying to connect to metastore with URI thrift://quickstart.cloudera:9083
2018-01-13 07:42:16,620 [main] INFO hive.metastore - Opened a connection to metastore, current connections: 1
2018-01-13 07:42:16,620 [main] INFO hive.metastore - Connected to metastore.
2018-01-13 07:42:16,652 [main] ERROR org.apache.pig.tools.grunt.Grunt - ERROR 1070: Could not resolve org.apache.pig.piggybank.evaluation.string.UPPER using imports: [, java.lang., org.apache.pig.builtin., org.apache.pig.impl.builtin.]