Sbt package needed

sbt

#1

Hello Pls install sbt package in gw03 for my user id. I tried installing sbt in local however there is some issue so could launch and do pacakaging… Pls help here


#2

Resolved sbt pacakge in gw03

however once i do compilation usng sbt… i get these errors
object apache is not a member of package org
[error] import org.apache.spark.sql.Row;
[error] ^
object apache is not a member of package org
[error] import org.apache.spark.sql.types.{StructType,StructField,StringType};
[error] ^
object apache is not a member of package org
[error] import org.apache.spark.sql.types.{StructType, StructField, StringType, IntegerType};
[error] ^

have added the dependcies in build.sbt also… pls fix this


#3

What is your login id on gw03.itversity.com?

@sunil.bhatraju


#4

@anbu

Can you paste the code you worked on? And also build.sbt file


#5

Hello this issue s resolved.

I added dependencies in build.sbt and right also assignment of sqlcontext
val sqlContext = new org.apache.spark.sql.SQLContext(sc)

kindly close this thread


#6

Hello this issue s resolved.

I added dependencies in build.sbt and right also assignment of sqlcontext
val sqlContext = new org.apache.spark.sql.SQLContext(sc)

build.sbt s as follows:

name := “retail”
version := “1.0”
scalaVersion := “2.10.6”
libraryDependencies += “org.apache.spark” %% “spark-sql” % “1.6.2”
kindly close this thread


#7