Unable to execute select count(*) query

hive
clouderaquickstart

#1

HI All,

I am a new HIVE leaner, whenever I run this select count(*) from deck_of_cards; I don’t get output, the executor stop in between and even if I run again in new terminal the same incident recurs.

Please find the below screenshot,


#2

@cpatro

Can you say the database and table name which you used. So that I can try and let you know.


#3

DB name- Cards
Table name- deck_of_cards

I guess there would be some issue from HIVE server. I am not sure. Please help me out.


#4

@cpatro

There is no table with name deck_of_cards in the database Cards.
I see the table name as deck_of_cardss. Moreover there is no data in the table. So it seems to be showing 0 records.


#5

Thanks Nikhil.

I am using my our lab environment of cloudera not from Durga Sir provided environment. Hence, I request a resolution for this.
Kindly, help me out.


#6

Hi,

Can you please help me on this? As I already mentioned I use my own cloudera lab for practice. Hence I am not getting any lines after the above screenshot.

Regards,
Sagar


#7

@cpatro

Can you share me the DDL statements for the table creation and insert. So that I can check on CDH5 installed on my vm.