URGENT Help Needed: sqoop export failed for unknown reason, thank you very much


#1

Here is the history: http://rm01.itversity.com:19888/jobhistory/logs/wn03.itversity.com:45454/container_e25_1520592249193_24420_01_000001/job_1520592249193_24420/paslechoix/syslog/?start=0

The command is as below:

sqoop export -m 1 \
--connect jdbc:mysql://ms.itversity.com:3306/retail_export \
--username=retail_user \
--password=itversity \
--table dep_export0322 \
--export-dir departments_new \
--input-lines-terminated-by '\n'

I also tried adding --input-fields-terminated-by ‘,’ with no success and no log

The data was imported with:
sqoop import
–connect=jdbc:mysql://ms.itversity.com/retail_db
–username=retail_user
–password=itversity
–table=departments
–target-dir=“departments_new”
–append

Actual data:
[paslechoix@gw03 ~]$ hdfs dfs -cat departments_new/* | head
2,Fitness
3,Footwear
4,Apparel
5,Golf
6,Outdoors
7,Fan Shop

The table is newly created with:
create table dep_export0322 (dep_id int, dep_name varchar(20), createdon date);

Any hint is greatly appreciated, thank you in advance.


#2

@paslechoix how did u create table in lab with data base we have write access , i tried creating table got error access denied


#3

you use retail_user, it has write privilege on retail_export