CCAH: Info required for VM

Hello Durga Sir,

Is it necessary to have licensed version of VMware to create 4 node cluster or free version of VMplayer will be enough ?

Hello @Shivkant ,

As per my knowledge, the free version of VMware workstation pro is a trial version only and valid for a month, after which you need to pay to use it further.

Hi @Sohail

I am asking about VMplayer free version, any idea about this?

Hello @itversity

Sir, please advise if VMplayer free version will be enough to create 4 node cluster.

Hi @Shivkant,

In VMPlayer, there is no option to clone from VMpalyer, so you need to manually clone the directories to make duplicates quickly. The information on manual cloning can be found over the internet easily. Apart from that i don’t see any issue in creating cluster using VMplayer free version. Hope this helps

Hi @itversity/ @Sohail,

I was creating 2nd VM manually. While setting up network I followed the same steps which I followed for the first VM.

I am able to access the VM address using IPaddress which I have given in the “ifcfg-eth0 file” by doing ssh via cygwin.

But when I run command ping www.google.com on VM itself, its giving error. Please suggest

Hello @Shivkant,

Usually when second VM is created, eth1 is active by default and not eth0. Please execute the following steps

  1. run “ifconfig -a” and check if eth0 is active or eth1

  2. if from the above command you notice that eth1 is active then run the command “ifconfig eth1 down” and then “rm -rf /etd/udev/rules.d/70-persistent-net.rules” and then reboot machine via “init 6” and check by running the command “ifconfig -a” again if eth0 is active. If active, then ping google to verify.

  3. if from the output of command in step 1 you notice that eth0 is already active then make sure of the following:
    a) the HOSTNAME and GATEWAY is set properly in /etc/sysconfig/network
    b) the HOSTNAME entry is present in /etc/hosts
    c) eth0 is assigned a unique IP address in /etc/sysconfig/network-scripts/ifcfg-eth0
    d) /etc/resolv.conf should contain the GATEWAY IP e.g “nameserver 192.168.XXX.XXX

Hi @Sohail,

I tried the same steps but still not able to establish internet connectivity on second VM.

Could you please help, I am stuck due to this.

Hi @itversity,

Durga sir, I am using VMplayer trial version, so I have to create 4 VM manually. But for 2nd VM creation I am not able to establish internet connectivity.

Could you please help.

Hi @Shivkant,

Paste the below data here.

  • output of command “ipconfig /all” from your windows machine

  • output of below commands from second VM

    • ping www.google.com
    • tracepath www.google.com
    • ifconfig -a
    • cat /etc/hosts
    • cat /etc/sysconfig/network
    • cat /etc/sysconfig/network-scripts/ifcfg-eth0
    • cat /etc/resolv.conf

Hi @Sohail

Please find the output as asked above.

******ipconfig output from windows:

CC:\Users\GOLI>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : GOLI-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Centrino® Ultimate-N 6300 AGN
Physical Address. . . . . . . . . : 3C-A9-F4-5A-99-84
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::40c1:595a:c257:34ea%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.103(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, February 03, 2017 4:41:30 PM
Lease Expires . . . . . . . . . . : Friday, February 03, 2017 6:41:30 PM
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 356297204
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-F2-CC-5F-3C-97-0E-C4-01-C6

DNS Servers . . . . . . . . . . . : 103.21.187.19
103.21.187.18
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® 82579LM Gigabit Network Connecti
on
Physical Address. . . . . . . . . : 3C-97-0E-C4-01-C6
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : F8-2F-A8-EC-F9-F6
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter VMware Network Adapter VMnet1:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
1
Physical Address. . . . . . . . . : 00-50-56-C0-00-01
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::c88a:72f0:e0b7:7503%19(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.138.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, February 03, 2017 4:41:39 PM
Lease Expires . . . . . . . . . . : Friday, February 03, 2017 5:26:38 PM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 192.168.138.254
DHCPv6 IAID . . . . . . . . . . . : 520114262
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-F2-CC-5F-3C-97-0E-C4-01-C6

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet8:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
8
Physical Address. . . . . . . . . : 00-50-56-C0-00-08
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f1b5:71ef:1fa9:36d3%20(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.70.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Friday, February 03, 2017 4:41:31 PM
Lease Expires . . . . . . . . . . : Friday, February 03, 2017 5:26:30 PM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 192.168.70.254
DHCPv6 IAID . . . . . . . . . . . : 536891478
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-F2-CC-5F-3C-97-0E-C4-01-C6

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
Primary WINS Server . . . . . . . : 192.168.70.2
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VirtualBox Host-Only Network:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : VirtualBox Host-Only Ethernet Adapter
Physical Address. . . . . . . . . : 0A-00-27-00-00-17
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::bdf6:a153:a661:a954%23(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.56.1(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 638189607
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-F2-CC-5F-3C-97-0E-C4-01-C6

DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter 6TO4 Adapter:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft 6to4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{23B44F9D-43D7-4A15-8847-34D6AFD409B4}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Reusable ISATAP Interface {C555C648-F5B5-4F7D-85C4-1DD670FA6821}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.localdomain:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{9778A2C2-2B2E-4FE9-A57F-A58F19289121}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #5
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

********[root@localhost ~]# ping www.google.com
ping: unknown host www.google.com

*******[root@localhost ~]# tracepath www.google.com
gethostbyname: Host name lookup failure

*******[root@localhost ~]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0C:29:D0:19:FD
inet addr:192.168.70.90 Bcast:192.168.70.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fed0:19fd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1894 errors:0 dropped:0 overruns:0 frame:0
TX packets:492 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:151383 (147.8 KiB) TX bytes:61012 (59.5 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4302 (4.2 KiB) TX bytes:4302 (4.2 KiB)

********[root@localhost ~]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

********[root@localhost ~]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=Goli002
GATEWAY=192.168.70.3

*******[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.70.90
NETMASK=255.255.255.0

*******[root@localhost ~]# cat /etc/resolv.conf
nameserver 192.168.70.3

Hi @Shivkant,

Are you able to ping your gateway IP 192.168.70.3? Please check.

First try to add host information as mentioned below in next post and then check if you are able to ping 192.168.70.3 and www.google.com. If not, then follow below steps

Configuration looks OK apart from the fact that you have DHCP enabled on your Windows Ethernet adapter VMware VMnet8. I have it disabled on my machines, so please try to disable it, configure the IP 192.168.70.1 manually for VMnet8.

After doing above, it still doesn’t work, then send me again all the data as below

output of command “ipconfig /all” from your windows machine

output of below commands from second VM

ping your-gateway-IP-here
ping www.google.com
tracepath www.google.com
ifconfig -a
cat /etc/hosts
cat /etc/sysconfig/network
cat /etc/sysconfig/network-scripts/ifcfg-eth0
cat /etc/resolv.conf

Hi @Shivkant,

You also need to add the host info in your /etc/hosts like below

[root@localhost ~]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
192.168.70.90 Goli002

Hi @Sohail

Please find the below data and advise.

[root@Goli002 ~]# ping 192.168.70.3
PING 192.168.70.3 (192.168.70.3) 56(84) bytes of data.
From 192.168.70.90 icmp_seq=2 Destination Host Unreachable
From 192.168.70.90 icmp_seq=3 Destination Host Unreachable
From 192.168.70.90 icmp_seq=4 Destination Host Unreachable
From 192.168.70.90 icmp_seq=6 Destination Host Unreachable
From 192.168.70.90 icmp_seq=7 Destination Host Unreachable
From 192.168.70.90 icmp_seq=8 Destination Host Unreachable
From 192.168.70.90 icmp_seq=10 Destination Host Unreachable
From 192.168.70.90 icmp_seq=11 Destination Host Unreachable
From 192.168.70.90 icmp_seq=12 Destination Host Unreachable

— 192.168.70.3 ping statistics —
13 packets transmitted, 0 received, +9 errors, 100% packet loss, time 12693ms
pipe 3

[root@Goli002 ~]# ping www.google.com
ping: unknown host www.google.com

[root@Goli002 ~]# tracepath www.google.com
gethostbyname: Host name lookup failure

[root@Goli002 ~]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0C:29:D0:19:FD
inet addr:192.168.70.90 Bcast:192.168.70.255 Mask:255.255.255.0
inet6 addr: fe80::20c:29ff:fed0:19fd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:390 errors:0 dropped:0 overruns:0 frame:0
TX packets:308 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:37410 (36.5 KiB) TX bytes:30850 (30.1 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:26 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2558 (2.4 KiB) TX bytes:2558 (2.4 KiB)

[root@Goli002 ~]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
192.168.70.90 goli@002

[root@Goli002 ~]# cat /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=Goli002
GATEWAY=192.168.70.3

[root@Goli002 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.70.90
NETMASK=255.255.255.0

[root@Goli002 ~]# cat /etc/resolv.conf
nameserver 192.168.70.3

Hi @Shivkant,

I reproduced the issue on my VM. Please change the gateway to “192.168.70.2” in /etc/resolv.conf and in /etc/sysconfig/network. Restart network service by “service network restart” and it should work.

Hi @Sohail,

It worked, thanks a lot.

Could you please explain what the issue was here because I have to create 2 more VM and how to avoid this again in creation of next 2 VM.

Hi @Shivkant,

I believe it was because of gateway address. You defined 192.168.70.3 but actually it should have been 192.168.70.2 as explained in Durga’s video also. For other VMs, just define 192.168.70.2 and it should work there as well. Thanks

HI @Sohail,

Is it okay to have same Gateway for all VM’s ?

Could you please share the link of that video also.

Regards,
Shivkant

Hi @Sohail,

Is it okay to have same Gateway for all VM’s ?

Could you please share the link of that video also.

Regards,
Shivkant

Hi @Shivkant,

Yes, you can use same GW for all VMs.

Look for the video with Title VMWare 04 Configure Network