Facing Errors during installation of cloudera manager (admin videos on vm's)

@itversity
Hello Durga Sir,
I am facing errors as in the screen shot below during the installation of cloudera manager in the playlist of cloudera hadoop on vm’s.
I did everything as mentioned in the video but i m struck here for two commands.1.yum update:i see a few errors as below 2. ./cloudera-manager-installer.bin --skip_repo_package :when i run this i again get the same error as u have got and when i visited the file as shown in the video and see the same errors in that page too.please clarify.
Thank you

@itversity
Hi Durga Sir,

Could you please help as per the above context…I am not able to install cloudera manager from my local repository and facing lot of errors in it.Please help!!!

Thanks in Advance!!!

@itversity
Hi Durga,

I did face the similar problem
Could you please help as i wasnt able to install cdm.

Thank you

Please provide these details

  • DocumentRoot from httpd.conf
  • Run this command as root find / -name "repomd.xml"

Your http server and yum repositories are not integrated properly.

@itversity
Thank you sir,parallel ssh worked.

Now when i am installing cdm on node1,as u got an error in cloudera-manager-installer/2.
but i got an error in cloudera-manager-installer/1.install-oracle-j2sdk1.7.log as shown in the below screenshot,and when i open that file and see,it looks as in the below screenshot .
Please help me resolve this issue and install cdm.

Thank you sir
vijay

@itversity

Just help in this CDM installation sir, as i have been struggling only on this since a while…i tried a lot but not getting resolved ,as its shattering my progress towards completion.

Thank you
vijay

You did not give the output I have asked for.

Your http and yum repositories are not integrated properly.

Attach httpd.conf, output of find command as asked before.

Hi Sir @itversity

below is the out for the command find command

[root@cdhserver1 conf]# find / -name “repomd.xml”
/var/www/docs/cdhserver1.itversity.com/cm5/redhat/6/x86_64/cm/5/repodata/repomd.xml
/var/www/docs/cdhserver1.itversity.com/cdh5/redhat/6/x86_64/cdh/5/repodata/repomd.xml
/var/cache/yum/x86_64/6/updates/repomd.xml
/var/cache/yum/x86_64/6/extras/repomd.xml
/var/cache/yum/x86_64/6/cloudera-manager/repomd.xml
/var/cache/yum/x86_64/6/cloudera-cdh5/repomd.xml
/var/cache/yum/x86_64/6/base/repomd.xml

@itversity

DocumentRoot /var/www/docs/cdhserver1.itversity.com

Also can you paste the error - instead of screenshot. It will make it easy to check whether the integration is proper or not.

Also run find command find / -name "oracle-j2sdk*.rpm" and see if jdk rpms are downloaded or not.

I think your rpms are not completely downloaded. Where are you based out of by the way?

Hello @itversity

I have run find / -name “oracle-j2sdk*.rpm” and i have received the following output sir
/var/www/docs/cdhserver1.itversity.com/cm5/redhat/6/x86_64/cm/5/RPMS/x86_64/oracle-j2sdk1.7-1.7.0+update67-1.x86_64.rpm
/var/cache/yum/x86_64/6/cloudera-manager/packages/oracle-j2sdk1.7-1.7.0+update67-1.x86_64.rpm

I am based out of Connecticut ,USA sir

The error i received while installing cdm is as below

oracle-j2sdk1.7 installation failed. See /var/log/cloudera-manager-installer/1.install-oracle-j2sdk1.7.log for details.

when i open that particular file its as shown in the screenshot ,as i am not able to get what the error is

It seems your binaries are not downloaded properly - http://www.checkupdown.com/status/E416.html

You might have to perform reposync again. Before doing again take size of repositories by running du -s -h commands.

Hello Sir @itversity

I have taken the size of repositories by du -s -h and got the below output
[root@cdhserver1 ~]# du -s -h
543M

I have again run reposync but faced the same problem again

oracle-j2sdk1.7 installation failed. See /var/log/cloudera-manager-installer/1.install-oracle-j2sdk1.7.log for details.

Thank you

You are not running du -s -h in right location. You have to run it in DocumentRoot.

Are you new to linux administration?

yes Sir,

learning everything from the scratch out of interest.

Your playlist is a great resource for me.

But not able to go through well, just because of cdm installation since a while…

I have run du -s -h in document root and received the following sir

Document root - /var/www/docs/cdhserver1.itversity.com

output-
[root@cdhserver1 cdhserver1.itversity.com]# du -s -h
2.8G

Pl help me out sir!!
Thank you in advance!!!

Where are you based out of?

@itversity
I am based out of Connecticut,USA sir