Got error creating database manager:

Hello all,

Not sure what mistake I’m doing here. can you please let me know why I can’t get pass this error while doing swoop import to hive table. Thanks

[bbastola@gw01 ~]$ sqoop import --connect “jdbc:mysql//” --username retail_dba --password itversity --table departments --hive-home /apps/hive/warehouse --hive-import --hive-table departments --create-hive-table
Warning: /usr/hdp/ does not exist! Accumulo imports will fail.
Please set $ACCUMULO_HOME to the root of your Accumulo installation.
17/01/18 19:10:45 INFO sqoop.Sqoop: Running Sqoop version:
17/01/18 19:10:45 WARN tool.BaseSqoopTool: Setting your password on the command-line is insecure. Consider using -P instead.
17/01/18 19:10:45 INFO tool.BaseSqoopTool: Using Hive-specific delimiters for output. You can override
17/01/18 19:10:45 INFO tool.BaseSqoopTool: delimiters with --fields-terminated-by, etc.
17/01/18 19:10:45 ERROR tool.BaseSqoopTool: Got error creating database manager: No manager for connect string: jdbc:mysql//
at org.apache.sqoop.ConnFactory.getManager(
at org.apache.sqoop.tool.BaseSqoopTool.init(
at org.apache.sqoop.tool.ImportTool.init(
at org.apache.sqoop.Sqoop.runSqoop(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.main(

At first point the connect string had syntax error- missing ":"
This should be : "jdbc:mysql://"
instead of "“jdbc:mysql//”

1 Like

Thank you ramesh.devarakonda.