Hadoop Installation error in Macbook Pro

I have tried to install Hadoop through Homebrew in my macbook pro and I am getting the below error as the issue to connect my localhost.ssh to localhost is working if I issue the command in the user login whereas the localhost port is not connected when I access through Hadoop command. Can you please help me to resolve this if anyone faced similar issue as I tried various solution provided in Google which is still not helping me to resolve the same.

End of File Exception between local host is: destination host is: “localhost”:9000; : java.io.EOFException; For more details see: http://wiki.apache.org/hadoop/EOFException

Which command is throwing this error?

Hi, Any hadoop filesystem commands like hadoop fs -ls displays the error message. It looks like the hadoop is not able to connect to my localhost. Could you please kindly help in this regard.
Thanks,

These issues cannot be troubleshooted so easily until you go to specifics.

  • Why are you setting up on Mac directly?
  • Why are you trying plain vanilla hadoop on Mac instead of having virtual machine images?
  • Are you aiming for developer position or admin position?