Putty is not working and getting error message

When i tried to connect through putty getting “Connection refused” error message.

Have you verified whether you are behind firewall? You can give a try with ip address -

Yes even i tried with IP addess also, getting same error message.
could you please provide complete hostname?

@rashmee We are able to login to machine successfully through SSH and Putty means server(VM) is working fine.

Can you provide what parameters you are filling in Putty ?

You could install Cygwin which is much better. At my job I use both and for user I select “Normal” and give your id. But maybe Durga has a different answer.

@rashmee, use mobaxterm, it works best. You have a built-in editor too. I found it better than other alternatives.

I have given ipaddress and hostname. Your PC might be behind firewall. Also you have to share the screenshot of what you are entering to establish connection.


seems I have the same problem with putty. I have a Windows workstation. No problems to connect with Cygwin windows:

c:\tmp>ssh wpietron@gw01.itversity.com
wpietron@gw01.itversity.com’s password:

But when connecting gw01.itversity.com server with putty 0.62 with default settings I get the following error:
Server unexpectedly closed network connection.
I get the same with putty when is used instead of hostname.

Anyone spotted the same issue?

Can you share the screenshot?

Yes, you are right we need to use sophisticated tools like cygwin, mobaxterm etc.


I attach the screenshot of the problem.

Thank you for your support.

Please try using Mobaxterm or Cgywin

I will try using putty and see if it is working fine. Mean while try with cygwin or mobaxterm.

Can you help to use Putty to login to the cluster? We have putty in the office, it will be helpful, it the provision is available to use putty to connect to the the cluster

What is the issue you are getting using putty?


have you got a chance to try using putty yourself and check if it is working fine for you?

Yes, it is working fine for me. Unless your office firewall block it, you should be able to use putty.

That is weird. I have no probs to connect using cygwin ssh but unable to connect from the same workstation using putty (with Windows Firewall and Antyvirus off). In the office I got the same but putty is the only option there. Any idea what else I should check?

You need to share screenshot before clicking on open/load. We need to validate whether you are passing correct information or not.

Here is the screenshot.