Sqoop import as Parquet File is failing

Hello ,

My sqoop import as Parquet file is failing. I tried going through the error and search online but could not resolve it. I tried by setting “-Dmapreduce.job.user.classpath.first=true” looking at previous discussion here. Even that did not help. Thanks in advance.

sqoop import -Dmapreduce.job.user.classpath.first=true --connect jdbc:mysql:// --username --password --table orders --warehouse-dir /user/akhilanand.bv_gmail/retail_db --driver com.mysql.jdbc.Driver --as-parquetfile

Error:

Application application_1492001640512_0078 failed 2 times due to AM Container for appattempt_149
2001640512_0078_000002 exited with exitCode: 1
For more detailed output, check application tracking page:http://ec2-52-44-197-32.compute-1.amazo
naws.com:8088/cluster/app/application_1492001640512_0078Then, click on links to logs of each atte
mpt.
Diagnostics: Exception from container-launch.
Container id: container_e49_1492001640512_0078_02_000001
Exit code: 1
Stack trace: ExitCodeException exitCode=1:
at org.apache.hadoop.util.Shell.runCommand(Shell.java:576)
at org.apache.hadoop.util.Shell.run(Shell.java:487)
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:753)
at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.launchContainer(Def
aultContainerExecutor.java:212)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.ca
ll(ContainerLaunch.java:303)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.ca
ll(ContainerLaunch.java:82)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Container exited with a non-zero exit code 1
Failing this attempt. Failing the application.

Can someone help me out on this issue plz…

@akil_anand

Can you try to use like the following

#As Parquet File
sqoop import
–connect jdbc:mysql://localhost:3306/retail_db
–username root
–password cloudera
–table categories
–target-dir /user/cloudera/cca175/review/sqoop_import/mysql_categories_as_parquet
–as-parquetfile
-m 5

I am trying the same command. No luck!

@akil_anand Ok.
Did you confirm whether sqoop works fine.

  1. Please check sqoop list-tables or sqoop list-databases.
  2. If it’s working then confirm whether you are able to import to HDFS.

Yup every other type import is working . I am getting this error only for parquet file format. Hence am puzzled what could possibly go wrong.

Could you paste the command you tried and output/error you are getting?