Sqoop Import failing


I’m getting the following error while importing using sqoop…

Warning: /usr/hdp/ does not exist! Accumulo imports will fail.

The query is as below.
sqoop import-all-tables
-m 12
–connect “jdbc:mysql://nn01.itversity.com:3306/retail_db”

Please help.


Accumulo is just warning. Did u get the imported data at the given location or not?

Please refer to the screenshot… It is saying not enough memory…

only --as-avrodatafile giving problem, try import --as-textfile / --as-sequencefile / --as-parquetfile these are working fine.

In the screenshot, I’m only listing the database. In that case also, it is giving me error. Also now Ambari console is not launching.

I am also facing Ambari console issue, for list-database you are missing the port number 3306

below is the example…

sqoop list-databases
–connect “jdbc:mysql://nn01.itversity.com:3306”
–username retail_dba
–password itversity

@sumansushovan92 - Refer the post Sqoop import failing in AvroFormat

its resolve the import into avro format issue, please close this after checking from your end.

Hi All, I tried importing-all in to my sqoop_import directory, but after running the command i can see only CATEGORIES table, rest all are absent. Can some one help me to know whats the issue?
[soori2980@gw01 ~]$ hadoop fs -ls /user/soori2980/sqoop_import
Found 1 items
drwxr-xr-x - soori2980 hdfs 0 2016-12-03 02:36 /user/soori2980/sqoop_import/categories
[soori2980@gw01 ~]$

Here is the explanation and solution

Thank you sir, after deleting the .java files it worked.